U.Time 1.1FREEU(niversal).Time is a multi-protocol network time client, written in C#. Both command line and GUI tools are available for .NET / Mono. U.Time supports SNTP (RFC2030) / Time (RFC868) / Daytime (RFC867) / HTP (via the HTTP Date header).Read More Rating:
TOP DOWNLOADSlast weekTemple Run: Oz326doPDF290radcam: digital camera286SpaceEngine227JioHotstar204Toca Boca World: Game & Play190CashMama- Instant Personal Loan App Online168 View All Top Downloads
LATEST ADDITIONSRecently Added SoftwareViễn Chinh Mobile - game PK2026-11-05Alettifag School2026-11-05Thapki Pyar Ki Songs2026-11-05McxCenter2026-11-05Ikeja Electric CEM Application2026-11-05Tarla Dalal2026-11-05dodolK Language pack(한국어)2026-11-05 View All Top Additions
LATEST UPDATESRecently Updated SoftwareViễn Chinh Mobile - game PK2026-11-05Alettifag School2026-11-05Thapki Pyar Ki Songs2026-11-05McxCenter2026-11-05Ikeja Electric CEM Application2026-11-05Tarla Dalal2026-11-05dodolK Language pack(한국어)2026-11-05 View All Updates